单臂路由

单臂路由

【引言】

今天学习了一下承载网的基础【二】之VLAN间路由的三种方案之单臂路由,以前一直没搞清楚单臂路由的概念和知识,乘着这个机会顺便学习了一下单臂路由的知识和配法。

单臂路由(router on a stick)是指在路由器的一个接口上通过配置子接口(逻辑接口,并不真正存在的物理接口)的方式,实现原理互相隔离的不同VLAN(虚拟局域网)之间的互联互通。

值得注意的是当路由器的某个物理接口被关闭时,该物理接口的所有子接口也将被关闭。

【安装设备】

这里我们使用的是思科的模拟器来实现单臂路由,我想原理应该是差不多的,以后有机会接触其他设备的再补上配置。

我们安放3台pc、1台路由和交换机,如图所示:

2.png

连线:同交异直

【数据配置】

我们安放好相应的配置和连线后,先为每台pc配置IP地址网关,我这里的pc配置如下:

PC名称IP地址网关地址
PC0172.16.3.1255.255.0.0
PC1172.16.4.1255.255.0.0
PC2172.16.5.1255.255.0.0

接下来我们进入交换机的CLI(命令行)模式进行配置:

Switch>enable

Switch#vlan database

Switch(vlan)#vlan 10

Switch(vlan)#vlan 11

Switch(vlan)#vlan 12

Switch(vlan)#exit

Switch#configure terminal

Switch(config)#interface fastEthernet 1/1

Switch(config-if)#switchport access vlan 10

Switch(config-if)#interface fastEthernet 2/1

Switch(config-if)#switchport access vlan 11

Switch(config-if)#interface fastEthernet 3/1

Switch(config-if)#switchport access vlan 12

Switch(config-if)#interface fa0/1

Switch(config-if)#switchport mode trunk      (把该接口设置为trunk模式)

Switch(config-if)#switchport trunk allowed vlan all       (运行所有vlan通过)

Switch(config-if)#exit

Switch(config)#end

接下来我们进入路由器的CLI(命令行)模式进行配置:

Router>enable

Router#configure terminal

Router(config)#int fastEthernet 0/0.1      (进入子接口)

Router(config-subif)#encapsulation dot1Q 10      (封装dot1Q协议,建立与vlan10的关联)

Router(config-subif)#ip add 172.16.3.254 255.255.255.0

Router(config)#int fastEthernet 0/0.2      (进入子接口)

Router(config-subif)#encapsulation dot1Q 11      (封装dot1Q协议,建立与vlan11的关联)

Router(config-subif)#ip add 172.16.4.254 255.255.255.0

Router(config)#int fastEthernet 0/0.3      (进入子接口)

Router(config-subif)#encapsulation dot1Q 12      (封装dot1Q协议,建立与vlan12的关联)

Router(config-subif)#ip add 172.16.5.254 255.255.255.0

Router(config-if)#no shutdown             (启动f0/0的接口,包括所有子接口)

【测试单臂路由】

如图所示测试成功:

1.png


回复列表



回复操作

正在加载验证码......

请先拖动验证码到相应位置

发布时间:2020-03-10 20:56:35

修改时间:2020-03-10 20:56:35

查看次数:81

评论次数:1